Jump to content
LIGISTX

The Blue Beast

Recommended Posts

5 hours ago, mariusvt said:

Man, you have shit luck with this car.  It's not your daily I'd call up this guy and see what your options are.  Maybe he does a core exchange so you don't have to worry about sending him yours, waiting for the rebuild, then reinstall.

https://www.facebook.com/Getragmt82/

Yea, I called Ben today. From what I understand... he is the MT82 guy.

 

Looks like about ~2200 bucks after I ship him my trans to get a "stage 1" trans which is removal of all internal plastic and replaced with brass or billet depending on which part, some "special sauce" tricks plus cryo and REM treated gears. I figure I will go for that full option since I really don't want to ship him it back lol.

 

Also, in the scheme of it, if this holds up as well as people seem to say, ~2500 bucks after everything isn't horrible. I do want to find out if I can play with gearing at all though. It would be nice to possibly go with the GT second and third gear, as well as 6th. I will be making some spreadsheets to see what would be optimal for my torque curve and tracks that I frequent.

Share this post


Link to post
Share on other sites

Fuck everyone.

Took us a while, but got my trans out. Both starter bolts where loose, 2 of the bells housing bolts where not even finger tight, and one of the cat pipe flange bolts where not even finger tight.

Can’t trust no one to do nothing 🤬🤬🤬

And obviously this was all the last mechanics fault cuz those parts all have to come off to drop the trans....


Sent from my iPhone using Tapatalk

Share this post


Link to post
Share on other sites

On the plus side. I may have found the reason for my meg race spec vibration at high revs. Talked to the owner of MGW, he said this shouldn’t be happening at all. Should make no noise and be tight AF. Still planning to send him mine as he said he will still give it all a look see to make sure. But... maybe, finally, one thing will be solved?

https://imgur.com/a/NWiFphw


Sent from my iPhone using Tapatalk

Share this post


Link to post
Share on other sites

My luck continues. Ben opened up my trans yesterday and sends me a FB message “trans looks great, what exactly was wrong?” For fucks sake, really..? So I call him and walk through the symptoms as he has it on his bench in front of him. He did say the gen 1 input shaft and drive gear have been known to wear badly, but mine didn’t show any visual signs of that. I have a gen 2 trans, but he said the early ones still used the gen one input and drive gear. So he looked a little harder and said one of the faces was a little sharp which shouldn’t be the case, and a previous v6 customer had a similar issue and it was fixed with the input and drive gear being replaced. So. Hears to hoping. New parts should be in by the end of the week, then all gears sent to cryo and rem, and hopefully my problem will be fixed. No one hold their breath for me, you will probably die...


Sent from my iPhone using Tapatalk

Share this post


Link to post
Share on other sites
On 10/9/2018 at 9:09 AM, LIGISTX said:

My luck continues. Ben opened up my trans yesterday and sends me a FB message “trans looks great, what exactly was wrong?” For fucks sake, really..? So I call him and walk through the symptoms as he has it on his bench in front of him. He did say the gen 1 input shaft and drive gear have been known to wear badly, but mine didn’t show any visual signs of that. I have a gen 2 trans, but he said the early ones still used the gen one input and drive gear. So he looked a little harder and said one of the faces was a little sharp which shouldn’t be the case, and a previous v6 customer had a similar issue and it was fixed with the input and drive gear being replaced. So. Hears to hoping. New parts should be in by the end of the week, then all gears sent to cryo and rem, and hopefully my problem will be fixed. No one hold their breath for me, you will probably die...


Sent from my iPhone using Tapatalk

Please tell me that you're the only one to have this problem. I can't be replacing the trans in a year or two... Lol.

Share this post


Link to post
Share on other sites
Please tell me that you're the only one to have this problem. I can't be replacing the trans in a year or two... Lol.


A lot of the early MT-82’s went bad. Basically, anyone who drove theirs hard on track blew it up. It was so bad, when I needed a new one ford didn’t have one to give me. Took 3-4 months to finally get it fixed, I hit high up the chain enough for the west coast regional customer relations manger to personally call me and put, what she claims, was the second to last one on the country on an overnight plane from NY to LA, and my car was done the next day.... it was a huge cluster, and put a horribly sour taste in my mouth for Ford. Yes, she dealt with the issue, but this was after months of headache, multiple different dealers giving me the run around, different service managers, shit I had service managers leave in between my car still being there. It was just a stupid shitty situation.

That said, I’m pretty sure this failure was due to s bad clutch instal 2 years and ~10k miles ago. I’ll never be able to prove it, and not worth the headache of suing someone over. But from what the last mechanic told me and the issue I have.... pretty safe bet.

But. Yea. Long story short, with all the issues I have had with my car and the way I have been treated by ford at every turn, o and the fact they routinely fuck my car and my fathers 5.0 up every time it goes into the dealer for work......... no more fords for me. I can’t recommend them anymore to people either. It’s to bad, the mustang is AN AMAZING value. But, that doesn’t make it good quality or a good service experience. You get a lot of war car for your money, but nothing else. I have had so much better luck at dealers with my stupid little daily commuter 2006 Honda Accord.

/rant


Sent from my iPhone using Tapatalk

Share this post


Link to post
Share on other sites
16 hours ago, LIGISTX said:

 


A lot of the early MT-82’s went bad. Basically, anyone who drove theirs hard on track blew it up. It was so bad, when I needed a new one ford didn’t have one to give me. Took 3-4 months to finally get it fixed, I hit high up the chain enough for the west coast regional customer relations manger to personally call me and put, what she claims, was the second to last one on the country on an overnight plane from NY to LA, and my car was done the next day.... it was a huge cluster, and put a horribly sour taste in my mouth for Ford. Yes, she dealt with the issue, but this was after months of headache, multiple different dealers giving me the run around, different service managers, shit I had service managers leave in between my car still being there. It was just a stupid shitty situation.

That said, I’m pretty sure this failure was due to s bad clutch instal 2 years and ~10k miles ago. I’ll never be able to prove it, and not worth the headache of suing someone over. But from what the last mechanic told me and the issue I have.... pretty safe bet.

But. Yea. Long story short, with all the issues I have had with my car and the way I have been treated by ford at every turn, o and the fact they routinely fuck my car and my fathers 5.0 up every time it goes into the dealer for work......... no more fords for me. I can’t recommend them anymore to people either. It’s to bad, the mustang is AN AMAZING value. But, that doesn’t make it good quality or a good service experience. You get a lot of war car for your money, but nothing else. I have had so much better luck at dealers with my stupid little daily commuter 2006 Honda Accord.

/rant


Sent from my iPhone using Tapatalk

 

 Man that sucks. I guess note to self, never use a ford dealer.

Share this post


Link to post
Share on other sites
6 hours ago, Stevethe11th said:

 Man that sucks. I guess note to self, never use a ford dealer.

Yea, it does suck. Quite a lot. I love my car, but man, the headaches I have been through with it really are out of this world. No one else would have gone through everything I have and came out the other side saying they love their car lol.

 

That said, I think I have been very unlucky. I can't see them actually being this horrible.... They would go out of business.

 

Although, that said, I did message ford directly on FB (lol, I know) when this trans blew up. I told them I am sure it isn't their fault due to the info I had, but just wanted to tell them the pains I have had with my car, and the lack of knowledge at every dealer I have dealt with. I mean, the latest example was amazing... When they WAY over torqued my lugs when they put my brembos on, they did agree to replace the studs at their cost. K, cool, sounds great. Well, the service MANAGER ordered lugs, not studs... And he was out on vacation so his second in charge dude calls me, tells me they will get it sorted right away. K... cool, sounds great. Calls me back 30 mins later "Sir, you have aftermarket studs, we have our best technician trying to determine what parts we need to order to make this exactly how it is now". Uh, what, the only "after market studs" are ARP, and I know I don't have ARP studs, and im pretty sure your tech knows that too........ Especially considering I don't have open end lugs and ARP studs are 3" long, and sorta gold instead of silver. So when I was like what are you talking about, no I don't, he basically hung up on me with "don't worry we will make it right". So obviously I call back, like uh wtf are you talking about, I DO NOT have aftermarket studs, and if I somehow do, I need to know about it since I am the original owner of the car and do 95% of the work myself, I need to know how this happened and wtf the current hardware on the car is. Well, he didn't like this, and basically hung up. I had to drive to the fucking dealer in 5 pm LA traffic, only for him to get annoyed I was there, refuse to tell me what they did end up ordering "I can't do that, that is handled by the parts dept, I don't have that info" I told him he needed to start to care about this and go figure it out since I thought maybe they ordered 4 sets of rears, or 4 sets of fronts (rears and fronts are a diff knurl thus diff part number). So I went in knowing all the info, talked to the second highest dude in the service dept, and found out the entire confusion was that he said LUGS when he meant STUDS. And he kept doing it, even when he showed me what they ordered, he said we got it sorted, got the right lugs on the way. For fucks sake, those are studs. What he MEANT in the beginning was I had aftermarket lugs, which has nothing to do with anything really...... Just tuns out stock lugs won't fit my rims, which is fine, SINCE THE LUGS ON THE CAR CLEARLY DO.

 

Anyways, I told ford this, along with the other issues I have had, and they said they will look into it, need VIN and miles. Sent them that, still to this day haven't read the FB message lol. #horribleservice

Share this post


Link to post
Share on other sites
4 minutes ago, LIGISTX said:

Yea, it does suck. Quite a lot. I love my car, but man, the headaches I have been through with it really are out of this world. No one else would have gone through everything I have and came out the other side saying they love their car lol.

 

That said, I think I have been very unlucky. I can't see them actually being this horrible.... They would go out of business.

 

Although, that said, I did message ford directly on FB (lol, I know) when this trans blew up. I told them I am sure it isn't their fault due to the info I had, but just wanted to tell them the pains I have had with my car, and the lack of knowledge at every dealer I have dealt with. I mean, the latest example was amazing... When they WAY over torqued my lugs when they put my brembos on, they did agree to replace the studs at their cost. K, cool, sounds great. Well, the service MANAGER ordered lugs, not studs... And he was out on vacation so his second in charge dude calls me, tells me they will get it sorted right away. K... cool, sounds great. Calls me back 30 mins later "Sir, you have aftermarket studs, we have our best technician trying to determine what parts we need to order to make this exactly how it is now". Uh, what, the only "after market studs" are ARP, and I know I don't have ARP studs, and im pretty sure your tech knows that too........ Especially considering I don't have open end lugs and ARP studs are 3" long, and sorta gold instead of silver. So when I was like what are you talking about, no I don't, he basically hung up on me with "don't worry we will make it right". So obviously I call back, like uh wtf are you talking about, I DO NOT have aftermarket studs, and if I somehow do, I need to know about it since I am the original owner of the car and do 95% of the work myself, I need to know how this happened and wtf the current hardware on the car is. Well, he didn't like this, and basically hung up. I had to drive to the fucking dealer in 5 pm LA traffic, only for him to get annoyed I was there, refuse to tell me what they did end up ordering "I can't do that, that is handled by the parts dept, I don't have that info" I told him he needed to start to care about this and go figure it out since I thought maybe they ordered 4 sets of rears, or 4 sets of fronts (rears and fronts are a diff knurl thus diff part number). So I went in knowing all the info, talked to the second highest dude in the service dept, and found out the entire confusion was that he said LUGS when he meant STUDS. And he kept doing it, even when he showed me what they ordered, he said we got it sorted, got the right lugs on the way. For fucks sake, those are studs. What he MEANT in the beginning was I had aftermarket lugs, which has nothing to do with anything really...... Just tuns out stock lugs won't fit my rims, which is fine, SINCE THE LUGS ON THE CAR CLEARLY DO.

 

Anyways, I told ford this, along with the other issues I have had, and they said they will look into it, need VIN and miles. Sent them that, still to this day haven't read the FB message lol. #horribleservice

Yeah that's how most companies, big or small, deal with complaints. They talk about how sorry they are and how they're going to fix it but in reality the complaint is going in one ear and out the other.

Share this post


Link to post
Share on other sites
2 minutes ago, Stevethe11th said:

Yeah that's how most companies, big or small, deal with complaints. They talk about how sorry they are and how they're going to fix it but in reality the complaint is going in one ear and out the other.

Unfortunately I know. I work for Northrop Grumman. I enjoy my job, and the people I directly deal with are all mostly great, the corporation is so broken its laughable. They have no concept of how to function correctly lol. Its so inefficient as an Industrial Engineer who's job is suppose to be to "optimize the enterprise", its painful. Some of that I understand due the nature of defense and secret keeping ect, but I can't even explain how broken it is in so many ways. They can't even get a grasp on making employees happy in the simplest of ways.

 

So much ranting today... lol

Share this post


Link to post
Share on other sites
2 minutes ago, LIGISTX said:

Unfortunately I know. I work for Northrop Grumman. I enjoy my job, and the people I directly deal with are all mostly great, the corporation is so broken its laughable. They have no concept of how to function correctly lol. Its so inefficient as an Industrial Engineer who's job is suppose to be to "optimize the enterprise", its painful. Some of that I understand due the nature of defense and secret keeping ect, but I can't even explain how broken it is in so many ways. They can't even get a grasp on making employees happy in the simplest of ways.

 

So much ranting today... lol

Just breath in and out, in and out... lol

  • Like 1

Share this post


Link to post
Share on other sites

Dealers here in northern Virginia are pretty awesome. I got a new trans despite having a bunch of bolt-ons and even residual rubber from a day at the dragstrip. Service adviser mentioned I should probably clean off the rubber from the wheelwells before bringing it by again. :smiling:

Share this post


Link to post
Share on other sites
Dealers here in northern Virginia are pretty awesome. I got a new trans despite having a bunch of bolt-ons and even residual rubber from a day at the dragstrip. Service adviser mentioned I should probably clean off the rubber from the wheelwells before bringing it by again. :smiling:


To their credit, I did get my new trans with a bunch of bolt ons as well. Even my aluminum DS and at the time Barton shifter bracket and AM shifter.

But, still, the fact it took them a month just to do anything, by which point everything was even more heavily backordered, it was just all horrible. The only good experience at a dealer was buying the car in the first place. Everything since has been bad.


Sent from my iPhone using Tapatalk

Share this post


Link to post
Share on other sites

So they didn’t send an explanation, but I messaged George (owner) to see if he has any idea if the old part was actually deemed bad. But, seemingly a bit of info going my way, MGW replaces the stick portion of the shifter.

This was the Gen 1, so it looked like this originally:
a1d6950ad92e7ada104d6f26893e4f04.jpg

Now this:
a4a0034b4aa556a094d23482fcb9cb6c.jpg

No idea what has changed from a design standpoint, hopefully he can shed some light, he is usually pretty good and informative. Great customer support and even better hardware. Can’t recommend MGW enough.


Sent from my iPhone using Tapatalk

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.