Jump to content

Recommended Posts

2 hours ago, Evil87GN said:

Hmmm, should I be a putz and re-intro myself...🤣

Yeah, yeah, one of the OG member has returned to the fold. I made the cardinal sin of going to Mopar, and ohhh boy do I and my bank account regret that decision. Picked up the '13 V6 a few weeks ago, and hoping my Scat Pack goes bye-bye after it's back on the road..again. Let's just say it has been a never ending nightmare with that damn thing. 

Fun has already begun with the Cyc....working on data logging/tuning via HP Tuners + have shorties and upgraded driveshaft waiting to go on soon. 

Welcome back!

Share this post


Link to post
Share on other sites
On 11/18/2019 at 8:21 AM, Unclenard said:

Welcome back!

Thanks much bud, and it's good to be back in a Cyclone. I'm probably re-inventing the wheel, but data logging the car via HPT and building a channel layout for the platform is definitely fun/interesting. I see you are still in the Tampa/St Pete area....I'm still up in Jax. I haven't been to OSW in a few years now though, not since I started putting my 392 back together. You can bet I will be rolling back down there soon to test the upgrades on the ol rattletrap Cyc. Panhard bar and sway bar end links are squeaking/rattling and driving me effing nuts..lol. 

  • Haha 1

Share this post


Link to post
Share on other sites

My neighbor had a 2016 black Scat Pack car, and he's sold his? He rarely drove it, and one time made it "Jump" from lane to lane with a blip of the throttle, scared him I'm sure,lol. Welcome back, what was wrong with the Dodge.

Share this post


Link to post
Share on other sites
On 11/23/2019 at 6:29 AM, Roanstang said:

My neighbor had a 2016 black Scat Pack car, and he's sold his? He rarely drove it, and one time made it "Jump" from lane to lane with a blip of the throttle, scared him I'm sure,lol. Welcome back, what was wrong with the Dodge.

Thanks for the welcome, and the SP has been a fun car...when I got to drive it. I had a massive brain fart in August of 2017 and broke it...sent #5 piston/rod into the oil pan. Note to self...don't tinker on the car when you've been up for 20+ hours & it's hot as hell in the garage. Bad combo, makes you forget where you left things that engines don't react to very well. 

Took a while to get the $$ together to fix it, then I decided wth it's being built right the first time. Full forged bottom end, ARP bolts/main studs, nice cam setup, etc. Lots of waiting on parts, machine shop back ups, and generally a royal PITA. Got it running again in April of this year. Did the oil changes, started logging/tuning, then went to the track for some gentle shakedown runs in mid May. 1st pass...spun, tagged the limiter for 1-1.2 secs by data log...short shifted it on down the track...heard a rattle. SO, car is back at the engine builder's shop, waiting for him to pull it out/investigate/repair. I've put 1400 miles on the car in 2+ years....while still making payments. At this point, ready to have a stock engine dropped back in so I can unload the orange nightmare. No Mo Mopar for me, unless it's a used Hellcat. 

  • Haha 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.